Trying to use the new API to pull targets associated with few diseases

Hi,
I am trying to use the new API to pull targets associated with few diseases, I wanted to get the association scores, target ID info, tractability (small molecule, antibodies, etc). I have downloaded the database locally but cannot find suitable documentation to perform what used to be a much straightforward task. Is there is any tutorials or something that can explain these data retrieval protocols? Doing that through the GUI is not practical.

Any reason the old API is not supported anymore. I had many projects that I cannot run anymore and I will need to develop from scratch to match the new requirements.

Thanks

Hi @mmahmed!

Thanks for your question.

We made the decision to replace our previous REST API with a GraphQL API to support the launch of the next-generation Platform in April 2021. GraphQL has some advantages we were interested in, such as language-agnostic access, a playground where users can run sample queries, and where users can view the complete API schema.

If you are unfamiliar with GraphQL, then we recently gave an introductory webinar for our API, which you can access here: Getting started with the Open Targets Platform GraphQL API - YouTube

We have examples of queries you can run here on the Open Targets Community that might be useful to you, for example: Returning all associations data using the Platform API or Using the API to search for drugs by target.

We have also included some sample Python and R scripts in our API documentation.

If there is a specific query you are having trouble with, please let us know and we’ll do our best to help!

Best wishes,

Helena

Thanks Helena,

I will try and get back to you.

I believe it could have been better if you added these new protocols to the existing API as additional features, and started replacing the old API gradually until the users get comfortable and are able to use the new API.

I am sure that many users had the same issue and many applications/codes that used to use the old API stopped working, which is, to be honest, very frustrating,

Anyway, thanks for help,
M